UH-1B-Huey-Gunship Starting at 500m and impossible to land

I have installed the Huey and Airland as instructed in MSFS.
When I try to start flight it immediately climbs away, not starting on the ground.
I have tried a few things but cannot get it to fly correctly.
I have attached the log file if someone could help please.

Hi David. Did you try any other helicopter like the R44? Do you have the same behavior?

Did you also confirm that you have the collective all the way down?

Hi Sergio, thanks for your reply.
I have just installed the R44 but I have the same problem. Less errors shown in the Airlands log as that has the atc-name etc configured.
Both choppers go up fast with my throttle fully closed, and the collectives confirm this.
Can you control the chopper’s throttle? Twist grip?


Looks like you either have an axis problem.

Do you have it assigned to Throttle or Throttle 1? Try both. You may need to invert the axis.

See if the collective moves as you move your axis, then check if it moves in the direction you expect it to be moving.

I only have Throttle and it is correctly set, fully forward collective down, as in a real chopper.
When I fly the Huey it shows on screen as two engines. There are certain elements of the config missing in the latest version I am sure.
The R44 still rises fast when I select fly and the Manifold pressure is flickering around 30, far too high, but the engine instrument does not function. After a little time playing with the throttle/collective it eventually settles down.
May be my PC is not powerful enough…

Mmmm. I find it weird that your computer couldn’t handle it. What are your specs?

I know some folks have issues with Airland but I never managed to find out why from talking to those users and Fred. You may be one of those unlucky persons.

Knowing your specs would at least allow me to find anything in common between people with problems using it.

I have a AMD FX 8350 Black Edition (4.0 GHz) on an
ASUS SABERTOOTH 990FX R2.0 with 16Gb and a Samsung SSD with the OS and another SSD dedicated to FS2020
My internet is terrible but it woks.

With the R44 loaded and Fly now selected I am on the runway all going but on the ground, collective down. I enter the config file in Airland and it immediately takes off.

Try having Airland working and with the profile loaded before entering MSFS.

Airland will not load the profile until the chopper is loaded at the gate, waiting for the final click to fly.

You can force the load of the profile yourself. Try doing that.

getting nowhere. If I force load Airland it just stops every time until the chopper is loaded.
I think it is a problem with the config files.
I have just been up again in the R44 but it is uncontrollable. I eventually get to the ground as the controls have a life of their own. Once down the engine idles. If I lift the collective a bit the engine picks up and the RPM gauge bursts in to life - it will not work before. But I cannot get off the ground as the collective is dead. The main stick is working but not the collective. I have reset the controls a few times but to no good.
Totally baffled.

You never tried to set the throttle to Throttle 1, have you? Could you try that?

I do not have throttle1, just Throttle.

You don’t have this option? You may need to change the filter to “All” (on the left)

when it is on Throttle 1 and I load the R44 to an airport it takes off as soon as I put the profile in Airland, never seen that before.
I will do a bit of searching.
Thanks for your help

Finally got the R44 and Huey flying correctly. Using Throttle 1.
There is a note on the site about the R44 that says Update 7 has changed the Assistance Options which has defaulted from OFF to ON and points to a Video. Select OFF many items under Piloting and Aircraft System.

Thanks for all you time.

1 Like

Awesome! Glad you got it to work!