P3D V4.5 Helicopter flying impossible

Hi guys

I’ve been using P3d for half a year now and i am at most satisfied. Nevertheless there is one major problem which seems to be software-issued.

When flying any type of helicopter, add-on or default, these most of the time don’t fly as they should. The rudders, elevators and ailerons are almost not responding, and if they do, it is sturdy, like in blocks and sudden stops.

Seen in VC, the controls from my joystick are perfectly translated to the movement of stick, pedals and collective, but the output to the model is that worse flying has become impossible.

Does anyone have likewise complaints? Who knows the fix for this?



They move by steps? That’s odd. I’ve never seen that behavior.

Sounds like a controler issue. Most of us that fly use FSUIPC5 for controlling our hardware. Especially for Helicopters. in most sims I find the default controller settings lacking.

Would it be the fact that i use an X-55 Rhino, which is a bit older than P3D? On the other hand, every move i make with stick, collective or rudder is perfectly done by the VC controls, but the helicopter doesn’t make the moves as it should. It doesn’t respond and then all of the sudden it does for a few seconds but totally out of proportion. It’s like the helo is holding itself steady for the whole time. R66, A109, Bell 212, MD900, MD530,… Bought and tried 'm all but no luck at all…

When i load the default scenario, then switch a helicopter and then move by selecting another airport it goes as normal for a while, but after some time it goes back to the issue again.


The biggest fear of every simmer: having an issue no knows or had before :smile: Nevertheless it’s frustrating me over the top as i can’t fly any helicopter in P3D.

Which helicopter are you using? Does it only happen in P3D?

Most of the time MilViz A109, but the same issue happens with all other helicopters, such as CeraSim B212, Alabeo R66, the default ones… I’ll try FS2004 tomorrow and see what it gives.

Check the Windows calibration tool to see if there are any “steps” as well.

No, it is as fluent as can be.

It does seem like an issue with P3D but a lot of folks use that stick. :frowning:

Yeah indeed. Re-install p3d yesterday and completely no difference at all. FS2004 works still perfectly on helicopters. Tried that an hour ago. Could it be because P3D V4.5 is not foreseen for helicopters yet? I’m thinking of installing P3DV3 to have a look

Do you just have issues with helicopters? Any other aircraft is fine?

Any other aircraft is fine indeedt. Only with helicopters i have this issue

That’s weird. I only have 4.4 so I can’t test it :frowning:

I’ll have myself a one-week subscription at P3DV3 and i’ll let you know what it gives! :wink:


So a small update on this one.

I’ve been using PDV3 for quite a while now. Just until yesterday everything went fine. And all of the sudden the problem came in this one too! I thought i was flippin’ out, as you can imagine.

Luckely, i remembered adjusting my settings in ActiveSky just before. And yes, having some new research solved it! It has to do with the “enhanced turbulence effect”. Switching it back to off (default) solves the issue. Switching it on has a very negative and unrealistic inpact on helicopter behaviour.

Hope this can be of any help for people having the same issue as i did before!