MD500 MSFS left skid down

With the latest version v1.0.2 I have to compensate the cyclic with the left skid down to stay in stable hover.
On the attitude indicator the angle is approx on the first indicator line.
Which is about 10 degrees of bank.

Now is slight low left skid mentioned in the changelog.
In VR however is my experience not slight low left skid.

Therefore the question is 10 degrees of bank the mentioned slight low left skid?

Left skid low is correct behavior in a hover for any helicopter with a CCW (Counter Clock-wise) rotor system.

This is due to translating tendency caused by the tail rotor countering the torque of the main rotor.
How much bank angle depends on the weight and balance of the helicopter. If you’re heavier, there will be more bank because more torque is required to hover.

So…whether or not 10 degrees is correct or not, depends on the weight of the heli, and where that weight is on the airframe.

Belatu is correct.

But no, 10 degrees is NOT normal at all. It shouldn’t be anywhere near that. Maybe 3 degrees. How did you update the helicopter? I’ve been having issues with people overwriting and doing exactly the opposite I say to to in the change log.

You have something setup wrong or something esle going on. Every since the updates ALL the helicopters hover more level than they uses to so I could get them to level off when at speed. So you messed something up because it’s the opposite.


Thanks for the reply.
I made the update by removing the old one and unzip the update in a new clean folder as noted in the changelog.

I suspected a problem on my systems because when starting hot the engine slowly shuts down and I can only start it and keep going by activating the autostart sequece by pressing CRTL-E.

I did found a problem with the battery switch getting stuck because of a Honycomb yoke switch keybinding.
This one is working correctly on all my other planes and helicopters including yours except on the MD500.

I have a lot of input devices connected. A honycomb yoke and throttle, a DIY collective, thrustmaster warthhog hotas and Cougar MFD, knobster and MFG Crosswind Rudder.
With a lot of key and axis bindings.
I already checked these and unplugged them but could not find any improvement.

Because you confirm that what I describe is not a what you experience I wil investigate my system again thoroughly on hard and software to pinpoint the problem.

1 Like

Hello Cowan,

ALL Problems are solved.

I went for a Vanila community folder and unzipped the files in there.
No problems no more.
Deleted the version in the renamed community folder and moved the vanila community folder version in the renamed community folder.

Then renamed the community folders back to their orginal names and tested it again.

To my suprise where all problems solved.

For your information.
The faulty install was already done after removing the previous version.

I suspect an unpak / unzip error for the faulty one.

Keep up the good work. I wll be one of your regular costumers

1 Like

Thank you for the report back!!! Not a lot of people report back. So thanks again. :blush:

No thanks needed. I find it rude not to give feedback.
But this is because I live on Feedback as an R&D engineer in daily live.
You need to give developers feedback in order to smash bugs.

With regards to bugs.
I found a potential one that I am investigating.
The spooling down of the turbine persist but only for now on a Freeware scenery I download from
Only CTRL+E autostart can restart the turbine and it stays on.
On spawning however it start to spool down and stop.

Its the helipad on the LUMC (Leiden University Medical Centre) in the Netherlands.
When I spawn on a runway of EHAM there is no problem.
This only occurs with your MD500 and not with any other helicopter I have. Including your Bell

Hello Cowan,

I looked into the spool down problem I have.
It is a hardware control and scenery issue.
On my Honycomb Alpha Yoke I have a GA profile and a MD500 profile.
In the MD500 are the binding to the left, right, both magneto and start NOT assigned.
In the GA they are assigned.
With this GA profile active the engine shuts down and no restart is possible. This is in all knob settings
With the MD500 profile there is no problem at all

Furthermore after working with a test vanila test community folder and restoring to my extended community folder I now have a Cold MD500 when I spawn on LUMC. This was the problem scenery.
Spawning on EHAM iengine is running and RPM is spooling down with dial reaching 9 o’clock before spooling up again.
Spawning on CYDF the RPM spools down and the dail is going to 6 o’clock before spooling up again. This takes also longer.

So its part Hardware (keybindings) and part spawning criteria on spawning points in scenery.

For now I have a work arround and reproducable results I can work with.
If this is behavour that is not intended for this model than I am willing to help you testing to solve this.

1 Like

Hello Cowan,

My latetst update report.
I now have found the reason for the odd behavior I was experiencing the MD500 and Bell.
TOO MUCH throttle.
I have asigned an axle to the Helicopter throttle and if this is all cranckt up the beheavior is a jumpy itchy collective and cyclic.
Turning it down gives a stable flight model.

I hope you can use this input.

Glad you figured it out. The governor controls the throttle in helicopters. There is an issue with this right now and doesn’t work correctly when mapped. No throttles should be mapped to anything. Only the mouse to roll to max for now. The needles should be in the green on the RPM gauge in all helicopters. When they fix the issues and finally get it right by letting us devs use the governor the way it should be then it will be fine. But no throttles for now. If it works for you then that’s up to you.

Mapped it as a habit because I use it all my other sims.
DCS, X-plane, Aerofly FS2
Its hard to loose a habit.
But now know the workarround for MSFS at current state

1 Like

Hello Cowan,

I want to give a last and final word on the problems I had.
After extensive testing with your models and with the Alluette 3 I have to conclude that its an Asobo end MSFS BUG.
I have mapped the helicopter throttle to an Axis and this is working in all the models.
The engine RPM is reacting with this Axis turned.
However when I start to fly with Throttle Axis full turned open the Flight model gets distorded and pulling the collective up will launch the helicopter into the air.
Starting with the throttle in the middle position will give a smooth working collective and a normal beheaving cyclic.

So the throttle axis is working but is not correctly implemented in the current version of the Asobo MSFS helicopter physics.

I will report this also to Asobo MSFS.

For now it is clear what was causing my specific problem and hopefully can you use this information.

1 Like

Thanks for reporting back. Yes, that was the issue from day one. They know about it. The first issue was that you could not programmatically turn off the governor, not even with the binding. That was fixed with the last sim update. Now the issue is as you explained. The throttle ignores the governor cap or max rpm. So Asobo needs to get it right. Lets hope for the sim update in August.