ND EC130 B4 engine startup problem


I recently purchased the Nemeth Designs EC 130 B4 which downloaded perfectly, installed perfectly, loads perfectly, and looks great on the tarmac. The problem is no matter what I do the engine won’t fire, as if it is starved of fuel while the starter is turning. But with fuel on board and the fuel pump on, throttle to idle (or any setting), rotor brake off, etc, following the checklist to a tee, it just won’t fire up.

It’s the strangest thing; I can start the Dodosim B206 in full manual mode which is a much more complex simulator but this is stumping me - there are so few controls so there are so few things that can be set wrongly, yet obviously something is.

It’s frustrating ‘cause all the hardware and software is working perfectly as far as I can tell, yet I still can’t get flying in what I can see is a beautiful aircraft.

If anybody else encountered and overcome this problem before, their help would be appreciated.

I’m running Windows 7, FSX with Acceleration.


Usually, “Ctrl” “E” starts the engine.

1 Like

If you’re starting from dark and cold, use the checklist. E.G. the rotor brake may need to be disengaged before the enine will start.

Hi Kittyhawk23,

Brilliant! I was so caught up with switches and checklists that I forgot to try the fsx basics, and it worked! Thank you! So that gets me up and flying which is the main thing.
Wow the flight model is different to any chopper I’ve tried before; its like trying to fly all over again, but that topic is for another day…
I’m hoping now that the aircraft is “switched on” that it will facilitate a proper checklist startup as well, but we will see.
Thanks again.

Hi DavidAllyn68,

Thanks for your help. I’d love to start from cold and dark but every time the chopper loads, all the switches are set ready for flight, even when I’m opening a saved flight where I had saved it as cold and dark.
I tried installing “Cockpit Sounds and Cold and Dark for ND EC130” gauge by Daniel Gauthier which works in terms of starting cold and dark, but then seems to block any use of the switches and dials by the mouse in my VC. So it’s not usable for me in that sense. Is there any other way to start cold and dark?
As for the startup, yes the rotor brake is off per the checklist. “control+e” has successfully got the chopper engine going, but whether this “control+e” is a one-time requirement after installation to switch something on in the background, or will be needed before every flight, I’ll need to check.
Thanks for the help.

In FSX, I think you need to start at a hanger or gate to be cold and dark. If you start on a runway or pad, it may start with engines running automatically. (I think - It’s been a long time). CTRL+E is an “in-cockpit” startup for that flight only and meant as a shortcut to going through the checklist - I prefer to go through the checklists myself. Good luck!