MSFS B206L3 V1.0.1 update gone wrong

The latest update on the B206L3 has some major issues if started from running.

The TOT, Torque and RPM gauges are all pegged to the max.
The governor switch is not affecting the rpm.
All controls are ultra sensitive, but maybe due to the RPM being overspeed?

this was from a loaded running state. I will test later from cold and dark.

After testing from cold and dark the behavior was correct on everything accept the TOT gauge.
It stayed above the redline after a normal start (Hot start?), but fuel was introduced at 12% on the gas producer.

I will do some more testing to see if I can achieve a normal start and gauge temps.

Not sure what’s going on here, but the first flight with the “nitrous shot” enabled happened when I chose a ramp start, but the “MSFS sometimes already running on the ramp” bug happened.

Here is what the gauges look like if the flight is started from running

I did some more testing and the TOT gauge is still not reading correctly during startup.
It doesn’t register any temp until the gas producer reads above 60, then it shoots up to 750. after spooling up to flight ready, the temp stays at 850. if you go fly, the temp drops back down and stabilizes in the green around 650. If you land and sit on the ground it goes back above 800…

I’m not exactly sure why, but only a few of you guys are doing it all wrong and I have to keep explaning this. The issue is user error NOT related to the helicopter software or update.

Pay attention to the change log. Read it all. How did you update it? Did you write over top of the old files??? Because that’s wrong and on the top of the change log page. Do you have the throttle mapped??? Do you have the governor switch mapped???

Obviously, your throttle is wide open, and the governor is NOT on.

It’s 100% obvious that I would not release something in that bad of condition, lol. Very obvious. So dig deep with your settings and process. You messed up somewhere along the line.

Throttle should be used with a mouse only and should be rolled to the max to activate the governor. Everything explained above was caused by you and your settings.

Nope. Followed the change log. Clean install of the new version.
I don’t have the throttle mapped, and have tested with controller profiles with, and without the gov switched mapped.

yes, it’s like the throttle is wide open when the issue occurs, but the throttle or governor don’t respond. The flight has to be restarted.

It still doesn’t explain the TOT gauge when starting from cold and dark. When everything is working and responding correctly, but the gauge temps don’t make sense. I will try to capture a video.

It’s never a good idea to directly insult a customer. I have been sticking up for Cowansim in my videos and on other forums. I know it’s a lot to deal with, all of the bs that is spewed on the internet, but accept the possibility that there is a variable that is being overlooked and that it is not user error.

If that’s insulting, then you wouldn’t ever want to hear my actual insults LOL. I’m very direct and yes it’s very stressful.

Are you using the beta? I don’t think there is one out yet, but I’m just making sure. I’m trying to replicate the issue.

1 Like

Can you try the 206B3 and see if you have the same issue??? If you don’t have it then I can send you a code to grab it. That will help narrow it down.

1 Like

I do have the B3 as well. I haven’t had any issues with it, so I haven’t done extensive testing.
The B3 is closest to my R44 experience, so it’s my go to choice in MSFS.
I’ll take it for a flight later and pay more attention…but so far in my casual flying the B3 has been perfect.

Trust me, I get the forum venting…

I love all of the nonsense I hear from non-pilots…
Yes I’m low time and need more experience, but sim pilots are not aware of how obvious it is when they try to claim that they are real pilots, and the real pilots can see their lack of specific knowledge.

It almost makes you want to stop helping people. I will also admit that sometimes, I’m already in a bad mood and take things harder than I should…

Keep up the good work. I love your models in XP and they are coming along nicely in MSFS.

I hear you on that 100%. This has been an intense learning process for me. Sometimes I get lost in it all and break down haha.

Well if the B3 is working fine for you then there must be some kind of conflict or difference with the L3. The flight model and engine are both different but based off of the B3. The code is all the same for the throttle interaction and most of the model XML RPN. I will have to do some deep digging to find the error or cause. Since the B3 works fine that proves I must have some kind of issue on my side. Weird that it’s not happening on my machine. Possibly the smallest typo and still probably related to hardware differences. I will be bouncing back and forth today to try to figure it out and replicate the maxed out RPM.


I will report back when I find something.

1 Like

I’ll keep testing and try to capture video of what’s happening.
Let me know if there is anything I can do or send from my end to help the process.

Yeah, the gremlins from machine to machine are hard to chase. I’ve gotten my dad into the hobby and we have almost the same setup, but he has intermittent sounds issues that I can’t figure out…


1 Like

I am experiencing the same problem.

  • I install mods using MSFS Addons Linker
  • I don’t overwrite files, I create new directories for each version and delete the old ones
  • I don’t have the throttle or gov switch or mixture mapped, I use a controls profile that I made specifically for your helicopters.

Here are more specifics after I did more testing:

  • Uninstalling all mods, launching the game, closing the game, and then re-launching with only the 206L installed does make the problem go away.
  • Reverting to 1.0.0 does fix the problem
  • The 206B does not have the problem
  • Reverting the fuel flow changes in engines.cfg on 1.0.1 does resolve the problem
  • This only affects runway/helipad starts, not cold starts
  • After spawning on the runway the behavior persists even if you shut down the engines and start it back up from cold & dark.

Effectively it makes 1.0.1 unflyable from airfields that don’t have parking spots, where you have no choice but to start on a helipad or a runway.

Problem seems to be related to the fuel flow changes, or at least the problem is exposed by the fuel flow changes.

With that said, Cold Start has a couple issues also.

  • The throttle defaults to “idle” instead of “off”
  • Unless you roll it back to “off” it will automatically begin introducing fuel as soon as the gas producer reaches 15%
  • In reality it should not introduce fuel before the IDLE RELEASE switch pops up.
  • The TOT gauge jumps from 0 to over 700 instantly during startup


I understand the tendency to assume that it’s user error. I do. Users traditionally do not read instructions and then don’t do any troubleshooting,.
But statements like this aren’t good:

It’s 100% obvious that I would not release something in that bad of condition, lol. Very obvious.

Nobody accused you of that. I think most people understand that it’s easy for minor changes to have unintended consequences, it’s easy to miss things when you have to test things manually, and shit happens. This has been reported by multiple people now who are just trying to make sure you’re aware of it so it can get fixed.

When you come out swinging and tell people that it MUST be their fault they will stop reporting bugs to you in the future. It’s the Linus Torvalds problem. They might also stop recommending and buying your stuff.

Anyway, hopefully I’ve provided at least some useful info. I hope you figure out what’s going on. For now I’ve simply reverted the fuel flow values in engines.cfg and my 1.0.1 is working fine.
fuel flow fix

I got it fixed guys!

The update is live and sending to resellers now. The marketplace version is just fine.

1 Like

And I agree with your statements. I can check everything 100 times and feel 100% confident about it, but I am human after all. I didn’t have the issue on my machine. How? I have no clue. But seems you are brilliant enough to have found the mistake yourself. Have a good weekend guys.

Now I need to test the new update…
Anyway…here is some raw footage of what’s been happening with the previous version.
It may still have some value so you can see what the TOT gauge is doing on startup of the B206B3 v1.0.3

I definitely know whats happening with the TOT. Not related. The sim just doesn’t simulate it well. Not unless I trick or fake it like I did with XP, slightly. Nothing new there at all… unless someone can simulate better than Microsoft hahha. If so, then let me know.

Fantastic work! I just tested out the new V1.0.2 B206L3 and the issues are fixed.

I figured as much for the TOT, that it really has more to do with the turbine simulation in MSFS.

Thanks for the tenacity on getting these bugs squashed!

1 Like

Great news. I wish I didn’t miss it on release but glad it’s sorted now. Have fun!

1 Like

No worries! I actually appreciate the fact that you are an actual human. I feel like it grounds the internet personas back in reality.

You have secured my support as a customer and user of your products.

1 Like