Change-log & updates

Hi everyone. I just wanted to touch base and start a thread for change-log and updates info.

There are some minor bugs that affect a small percentage of users right now. The fixes will be in the very first update.

  1. Cyclic in VR. The manipulator settings inside of the “500E_vrconfig” file in the main directory needs a change to work properly. This only affects users who do not use a physical joystick or cyclic, but use only the VR controller to grab the virtual cyclic to fly. If you want to fix this issue before the update comes out then you can use what is below. Simply open the “500E_vrconfig” and replace the similar section under “YOKE”.

BEGIN_MANIP drag_xy sim/cockpit2/controls/yoke_roll_ratio sim/cockpit2/controls/yoke_pitch_ratio
YOKE_MANIP_ROTATE -0.208478 -1.458990 0.519861 1 0 0 -3 3 -0.208478 -1.458990 0.519861 0.000000 -0.000000 1.000000 3 -3
END_MANIP

  1. The ADF receiver. For some reason the ADF power is randomly shutting off. Maybe corroded wires? This is being investigated and will be fixed in the first update.

  2. The throttle. This is just a visual flaw. If you’re using physical hardware to control the twist throttle then when at max rotation the animation will flicker. The link below can be downloaded and extracted into your main 500E directory to fix this issue. Simply extract and overwrite. Make sure you do it to both if you’re using 4K and 2K.

  1. Strobe. The draw order got messed up when last edits were happening so the strobe light on the tail is hidden. Sorry, this will also be in the very first update.

  2. If you’re having issues with the throttle mapping then make sure you follow the manual. There have been lots of users confused with this part. Mapping a hardware device to the throttle requires mapping that device to “wing sweep” NOT “throttle”. Simple fix.

  3. If you pull on the collective and the helicopter jumps off of the ground uncontrollably then you have not set up your collective correctly. It’s backwards. To correct this set your collective axis up by clicking the reverse check box. I know, it sounds backwards, but this axis should be reversed for most users.

  4. In rare cases the helicopter may “bounce” around on the ground while sitting with the engine off. If this “jittering” is happening on your machine then you need to increase the model frames as the manual states. Go to “settings”, the “general” tab, down to “flight model” then change the “flight models per frame” up a notch. If it’s still happening then up another notch until it’s not happening. This is rare for this bird but a couple people have mentioned it.

We want updates to have some weight to them so it will be a bit before these items are fixed and much more is added. No date but I will say soon. I hope you enjoy the helicopter as much as I do. She has a bright future. Stay tuned.

You can find the change logs on my website as well.

Have fun!

Josh

1 Like

The throttle is working great now. I just had to remember to set the slider to wing sweep, not throttle. I remembered that trick from Joe Rowe’s Bell 206, and was pleasantly surprised that it worked. I looked all over the helicopter for the strobe light switch, to the point I even looked in the back seat, (seriously, who does that?). I was impressed that there were light switches back there for the passengers. Now that is attention to detail. The model looks stunning in the detail all through out. Loving that so far, and it looks good in green! Thanks for the work Joshua. You hit this one out of the park.

1 Like

I can’t help but laugh, as I deal with hardware issues like this way more than software issues :rofl:

1 Like

@Dennis I was so confused when I noticed the strobe missing. I was in the middle of actually enjoying it after releasing and noticed. Big ooooops! Thanks for the compliments! :slight_smile:

@lonespace I couldn’t help it! :joy: I literally thought about checking the connections BAHAHH! Sometimes this simulation gets me in over my head, especially in VR. :laughing:

Speaking of releasing something and enjoying it and noticing a big oops, I was flying my CVA repaint when I noticed, I’d forgot to add the tail rotor warning arrows on the tail. I can’t remember if I added them for the update. The update covered mostly things like missed spots where white was showing when it should be green. One of these days I’m going to release a repaint that doesn’t need an update. (I keep telling myself that.)

1 Like

Sneak peak of some options coming in the first update early April.

1 Like

500E v1.10 – 4/10/2021

If something you requested or reported was not fixed or added then don’t worry. This is an ongoing project and will be updated further. Development takes a LOT of time, but we will get there. A new system for reporting bugs and requesting additions or changes will be added to this website soon. All messages are appreciated but need to be consolidated so I can continue with development.

Added tons of liveries

There were quite a few liveries added to the package. We decided to stop at 50 for overkill reasons. If for some reason you don’t want tons of cool liveries then you can open up the “liveries” folder and delete them. Simple.

New paint kit

The paint kit was upgraded and a paint kit for the cargo pod was added to the package. Thank you Pasiel J for your help. The new kit is amazing.

Some more additions

  • Added the missing keys. The starter will not work unless on.
  • Added click spots to remove EITHER fire extinguisher.
  • Added a hot start notification pop up and reset click spot. Let the engine wind back down before clicking reset.
  • Added several FMOD sounds and remixed/replaced a lot. Still a work in progress. We could spend months on sounds alone. Listen for the hot engine cooling after shutdown. Joe Kipfer…
  • Added/changed/updated textures and normals.

Added more Options:

  • Pilots and passengers
  • Cargo pod
  • Skid mirror
  • Remove duel controls
  • Standard Panel
  • Wire cutters
  • Utility floats

All options are added to the persistence script so they will be saved between your sim time.

Fixed Cyclic in VR

The manipulator settings inside of the “500E_vrconfig” file in the main directory needed a change to work properly. This only affected users who were not use a physical joystick or cyclic, but using only the VR controller to grab the virtual cyclic to fly.

Specifically this:

BEGIN_MANIP drag_xy sim/cockpit2/controls/yoke_roll_ratio sim/cockpit2/controls/yoke_pitch_ratio
YOKE_MANIP_ROTATE -0.208478 -1.458990 0.519861 1 0 0 -3 3 -0.208478 -1.458990 0.519861 0.000000 -0.000000 1.000000 3 -3
END_MANIP

Fixed ADF receiver

The ADF power was configured improperly and would not come on with the battery toggle.

Fixed throttle animation

This was just a visual flaw. If you were using a physical hardware device to control the twist throttle then when moving through max rotation the animation would flicker.

Fixed Strobe Light

Initially this was thought to be a draw order issue but it turns out the strobe was not connected to the beacon light toggle.

Fixed Anti Collision and Position lights that were backwards.

Fixed COMM & NAV 1 frequencies.

Fixed fuel flow issue on start up.

Adjusted fuel consumption.

Fixed several instrument/device lighting issues.

Fixed the save button in the VR config menu.

Corrected typos in textures.

Switched fuel cut off valve to be closed (IN) by default.

Adjusted fuel cut off on throttle.

Adjusted rotor brake strength.

Adjusted horsepower.

Adjusted skid flex animations.

Coded custom ammeter behavior.

Adjusted oil pressure.

Oil temperature coded to be at ambient temperature until above.

TOT temperature coded to be at ambient temperature until above.

Added code for smooth gauge needle animations when battery switch cut off.

Re-ignition light works when testing now.

Center window framing, windows, trim all narrowed. It was too wide.

Made grab handles thicker.

Several flight model changes. The Floats have drag when active and 0 drag when not active.

Hope you all enjoy the first update!

Josh

1 Like