Bell 407 Install Issues

Hello all,
I have purchased the ND Bell 407. At present I cannot seem to install it. Win 7 64bit, P3DV4.5
At about the 70% mark or so on the install screen I get a message that says:

File corrupt or unreadable

Has anyone else run into this? If so, what was your solution?
Thank you in advance

Last: I did send a message to the developer but have not heard back yet. If I get a solution I will report it here.

Hello all,
a quick update. I finally got the install to go through. Hopefully this post can stay up so others that may run into issues will have an easy reference.

Ok so even though I had my Avast shield off for the install, apparently I needed it off for the download. So:
If your going to download and install ND407 disable your antivirus for the download as well!

After all that it should work ok.

We use a bit old - but reliable - installer system so some anti-virus programs might mistakenly think that it is a malware but I can assure you it is 100% safe.

Hi Tamas,
I’ve the same problem but with a different file
I’ve re downloaded the installer even from another Pc and a Mac
Redone the installation a lot of times but I’ve always the same problem.
I’ve tried excluding the antivirus, but no difference.
Any idea?

I’ve solved the problem!
Very hard to do because there was a problem in one of the downloaded files, but was impossible to know what is the corruptdd files (dimension correct, antivirus excluded both in downloadind and installing).
SO the solution is:
download and try to install until it works.